Overview
The following error could appear immediately following an application launch, or during the application installation process. The RVM was unable to connect to the server hosting the OpenFin Runtime.
Potential Causes:
- The 'Assets URL' is invalid
- The server hosting the Runtime is unavailable
- The network path to the server hosting the Runtime is not open
Troubleshooting steps:
- Copy the full assets URL from the error and paste into a Web Browser, this should initiate a file download. If the file download works compare the Browsers network configuration with the local systems default settings.
- If the download fails in the step above:
- Check with the local network team that the network path to the URL is open
- If the URL is https://cdn.openfin.co/runtime contact support@openfin.co to verify the server is operational
- If the URL is not:https://cdn.openfin.co/runtime check with the application provider that the URL is correct, and the server is operational
- Check the network.log file, located in %LocalAppData%\openfin\logs for errors that have been returned by the network stack. You should be able to find the request for the runtime:
[1234:12345] INFO- Get request for url: "https://cdn.openfin.co/release/runtime/9.61.36.36"
- Validate the logged in user has permission to access the Assets URL, and is able to download and extract .ZIP files
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