Overview
The legacy Lightweight OpenFin installer displays a console window to the end-user during the installation process.
An `Error getting latest RVM version: SendRequest` Error error may appear in the Installer UI console window if the installer could not download the OpenFin Runtime Version Manager (RVM).
For more information on the OpenFin Lightweight installer please see our article here: https://openfin.zendesk.com/knowledge/articles/360017968032/en-us?brand_id=2790986
Potential Causes
- The local machine is not connected to the Internet
- The network path to the hosted RVM is not open
- The RVM location URL is invalid
Troubleshooting steps
- Ensure the local system is connected to the internet
- Open the installer.log located in %localappdata%\openfin\logs, find the line:
Getting latest RVM version from <url>
Copy the URL found in the log into a browser which should initiate a download of the RVM. If the download fails:- Check with the local network team that the network path to the URL is open
- If the URL is https://cdn.openfin.co/release/rvm/latestVersion contact support@openfin.co to verify the server is operational
- If the URL is not: https://cdn.openfin.co/release/rvm/latestVersion check with the application provider that the URL is correct, and the server is operational
- If the download succeeds in a browser, compare the browsers network setting with the system default settings (The installer uses the system default)
Manual Installation
An alternative solution would be to download and install the RVM manually:
- Download the RVM from https://cdn.openfin.co/release/rvm/latestVersion
- Add a .zip extension to the downloaded file
- Extract the openfinRVM.exe file into %localappdata%\openfin
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