Overview
Message Source Source: RVM Log / Modal
At application launch, an error reporting 'Application's client ID was not on the whitelist' is thrown when the Local system has a Desktop Owners file configured with an Application Whitelist, and the applications License Key has not been added to the whitelist. More information on the Application Whitelist feature can be found here: https://developers.openfin.co/docs/desktop-owner-settings#section-whitelist-applications-example
Potential Causes
- The Application Whitelist configured in the Desktop Owners File does not contain the Applications License Key in the clientID field
- The Applications Configuration file is missing a valid license key
Troubleshooting steps:
- Verify the License Key configured in the application
- Open the application configuration file URL in a browser (this can be found in the application shortcut, or in the RVM.log)
- Confirm the file contains a licenseKey entry, and note the value
- Evaluate the Desktop Owners File Application Whitelist
- Review the RVM log, search for 'DesktopOwnerSettings JSON:', the lines after this output should be the content of the Desktop Owners File
- Search the Desktop Owners File content for the whitelist -> allowed, list.
- The License Key discovered in step 1 should be listed as a 'clientId'
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