Overview
Log file: rvm.log
When an application is launched on OpeFin, the Runtime Version Manager (RVM) will check if the Runtime version specified in the Application Configuration file is available on the local system. If the required runtime is not available the RVM will download the runtime from the assets server.
This error will be output to the rvm.log file if the RVM was able to download the runtime but was unable to extract the downloaded zip file.
Potential Causes
- The user/local RVM does not have write access to the 'Runtime Directory'
- The user/local RVM does not have permission to extract downloaded zip files
- Security software is blocking the zip extension
Troubleshooting steps:
- Verify with the local IT team if the local user, and/or Runtime Version Manager has sufficient rights to write to the Runtime Directory
- Verify with the local IT team if the local user, and/or Runtime Version Manager has sufficient rights to extract downloaded zip files
- Check the event log of ay security software has quarantined the zip file after download or has blocked the extraction of the zip(check windows event viewer or antivirus logs).
Resolutions
Manual Runtime Installation
If it's not possible to resolve any admin right issues within a reasonable timeframe then a manual Runtime installation can be attempted, details can be found in our 'How To Manually Download The Runtime' article.
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